Re: [Rd] Possible Latex problem in R-devel?

From: Peter Dalgaard <p.dalgaard_at_biostat.ku.dk>
Date: Tue 24 Aug 2004 - 06:46:18 EST

Peter Dalgaard <p.dalgaard@biostat.ku.dk> writes:

> Prof Brian Ripley <ripley@stats.ox.ac.uk> writes:
>
> > On Mon, 23 Aug 2004, Jeff Gentry wrote:
> >
> > > I'm getting this error when installing packages w/ a checkout of R from a
> > > a little bit ago (23-Aug-2004, approx 1pm eastern US time):
> > >
> > > ** help
> > > Bareword found where operator expected at
> > > /usr/home/jgentry/R/share/perl/R/Rdconv.pm line 2331, near "$latexout
> > > latex_link_trans0"
> > > (Missing operator before latex_link_trans0?)
> > >
> > > It isn't obvious to me what the error is, although commenting out line
> > > 2331 definitely causes the error to go away.
> >
> > What version of perl?
> >
> > It works correctly in the current 5.8.4 (it has installed all the CRAN
> > packages), but I think I have seen something similar in 5.8.0. Making
> > that
> >
> > print $latexout &latex_link_trans0($blocks{"name"});
> >
> > will probably solve it for you.
>
> RedHat 8 is actually on 5.8.0 and is affected by this nit. Could we
> fix it in the sources? Would be nice if it doesn't turn into yet
> another must-upgrade-this-tool for developers.

Looks like Brian flew back in his time machine and responded to my request an hour or two before I stated it...

-- 
   O__  ---- Peter Dalgaard             Blegdamsvej 3  
  c/ /'_ --- Dept. of Biostatistics     2200 Cph. N   
 (*) \(*) -- University of Copenhagen   Denmark      Ph: (+45) 35327918
~~~~~~~~~~ - (p.dalgaard@biostat.ku.dk)             FAX: (+45) 35327907

______________________________________________
R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Tue Aug 24 06:54:13 2004

This archive was generated by hypermail 2.1.8 : Wed 03 Nov 2004 - 22:45:08 EST