Re: [Rd] Is this a problem with methods??

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Fri 27 Aug 2004 - 17:04:17 EST


Does your package have methods in the Depends: line in its DESCRIPTION file?

Are its data files self-sufficient (that is work without either the package or methods being loaded)?

R-devel is under development and before release we will make detailed advice available to developers. But see the draft at

        http://developer.r-project.org/200update.txt

It's almost certainly a problem with your package not loading methids when it needs to.

On Thu, 26 Aug 2004, Gustavo Corral wrote:

> Dear R-devel list members,
>
> we have developed a package and it works perfect in R 1.9.1 but when we
> prooved with R-devel we get the next output from the R CMD check:
>
>
> Error in eval(expr, envir, enclos) : couldn't find function "@<-"
> Execution halted
> ERROR: installing package indices failed
> ** Removing '/home/pgomez/genArise.Rcheck/genArise'
> ERROR
> Installation failed.
>
> We think this is a problem with methods, but we can't find how to
> correct it and we are stuck. I do not have the source code now to be
> more specific but maybe an error is obvious. I will send a new mail
> tomorrow with more details.

-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Fri Aug 27 17:16:32 2004

This archive was generated by hypermail 2.1.8 : Wed 03 Nov 2004 - 22:45:10 EST