RE: [Rd] Problem with Rcmdr Help menu under devel version of R 2.0.0

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Sun 29 Aug 2004 - 16:32:43 EST


You need to print the result of help. From NEWS

    o	help() now returns information about available documentation for
	a given topic, and notifies about multiple matches.

and (unstated) does not print.

Brian

On Sun, 29 Aug 2004, John Fox wrote:

> Dear list members,
>
> As an addendum to my previous message, Help buttons in Rcmdr dialogs --
> which generate calls to help() -- also fail to bring up corresponding help
> pages.
>
> Again, any assistance would be appreciated.
> John
>
> > -----Original Message-----
> > From: r-devel-bounces@stat.math.ethz.ch
> > [mailto:r-devel-bounces@stat.math.ethz.ch] On Behalf Of John Fox
> > Sent: Saturday, August 28, 2004 10:53 PM
> > To: r-devel@stat.math.ethz.ch
> > Subject: [Rd] Problem with Rcmdr Help menu under devel
> > version of R 2.0.0
> >
> > Dear list members,
> >
> > I've encountered the following problem with the Rcmdr Help
> > menu in the development version of R 2.0.0 under Windows XP
> > ("Version 2.0.0 Under development (unstable) (2004-08-20),
> > ISBN 3-900051-00-3"):
> >
> > The main Commander window has a (tcltk) Help menu with three
> > items, "Commander help", "About Rcmdr", and "Introduction to
> > the R Commander", which, in the development version of the
> > Rcmdr package, call the following three functions:
> >
> > helpCommander <- function() help("Commander")
> >
> > helpAboutCommander <- function() help("aboutRcmdr")
> >
> > browseManual <- function() {
> >
> > browseURL(paste(file.path(.path.package(package="Rcmdr")[1], "doc"),
> > "/Getting-Started-with-the-Rcmdr.pdf", sep=""))
> > }
> >
> > (Of course, there are help pages for "Commander" and
> > "aboutRcmdr" in the Rcmdr package).
> >
> > These functions are not exported by the Rcmdr package, but as
> > near as I can tell, that doesn't seem to be the source of the problem.
> >
> > The third menu item works fine, but the other two [which
> > contain calls to help()] appear to do nothing. I've tried
> > several variations, including specifying the package argument
> > to help() and using ? in place of help(), but to no avail.
> > Curiously, calling, e.g., Rcmdr:::helpCommander() directly
> > from the R command prompt works just fine.
> >
> > Unrelated to the above, I've also encountered some MD5
> > checksum problems with R 2.0.0 binary packages for Windows
> > installed from CRAN:
> >
> > ------------- output --------------------
> >
> > files R/car have the wrong MD5 checksums files R/effects have
> > the wrong MD5 checksums files R/multcomp have the wrong MD5
> > checksums files R/relimp have the wrong MD5 checksums
> >
> > ------------- end ---------------------
> >
> > Finally, there seems to be a dependency problem with the
> > lmtest package Windows binary installed via the "Packages ->
> > Install package(s) from CRAN"
> > menu in the R Console:
> >
> > ------------- output --------------------
> >
> > > local({a <- CRAN.packages()
> > + install.packages(select.list(a[,1],,TRUE), .libPaths()[1],
> > + available=a,
> > dependencies=TRUE)})
> > trying URL
> > `http://cran.r-project.org/bin/windows/contrib/2.0/PACKAGES'
> > Content type `text/plain; charset=iso-8859-1' length 18348
> > bytes opened URL downloaded 17Kb
> >
> > also installing the dependencies 'sandwich', 'zoo', 'strucchange'
> >
> > trying URL
> > `http://cran.r-project.org/bin/windows/contrib/2.0/sandwich_0.1-3.zip'
> > Content type `application/zip' length 75982 bytes opened URL
> > downloaded 74Kb
> >
> > trying URL
> > `http://cran.r-project.org/bin/windows/contrib/2.0/zoo_0.2-0.zip'
> > Content type `application/zip' length 53003 bytes opened URL
> > downloaded 51Kb
> >
> > trying URL
> > `http://cran.r-project.org/bin/windows/contrib/2.0/strucchange
> _1.2-4.zip'
> > Error in download.file(url, destfile, method, mode = "wb") :
> > cannot open URL
> > `http://cran.r-project.org/bin/windows/contrib/2.0/strucchange
> _1.2-4.zip'
> > In addition: Warning message:
> > cannot open: HTTP status was `404 Not Found'
> > >
> >
> > ------------- end ---------------------
> >
> >
> > Any help would be appreciated, particularly with the problem
> > I'm experiencing with the Rcmdr Help menu.
> >
> > Thanks,
> > John
> >
> > ______________________________________________
> > R-devel@stat.math.ethz.ch mailing list
> > https://stat.ethz.ch/mailman/listinfo/r-devel
>
> ______________________________________________
> R-devel@stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel
>
>

-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Mon Aug 30 10:21:43 2004

This archive was generated by hypermail 2.1.8 : Fri 18 Mar 2005 - 08:59:57 EST