RE: [Rd] having trouble building r-devel

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Wed 08 Sep 2004 - 16:48:13 EST


On Wed, 8 Sep 2004 Mark.Bravington@csiro.au wrote:

> When I set PATH to start with a dot (looking at the INSTALL file section
> on "Check your path"), "make" fails again with the
> ".install_package_description" error.
>
> So it looks like either (i) the documentation should be changed to tell

> the user to reset the path manually (and NB the dot isn't useful for

> Windows 2000),

It was when I ran Windows 2000. What's wrong for you?

> or preferably (ii) "make" needs to temporarily change the
> search path, or to look more explicitly for the new R.exe file. Or I've
>
gotten my wires crossed...

The latter. Try commenting out

# path (possibly full path) to same version of R on the host system ink1">#ink1">ink1"> R_EXE=R
^^

in MkRules. It's uncommented there from experiments with cross-compiling. Works for me.

BTW, getting R-devel to cross-compile has been a nightmare, but has been achieved.

-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Wed Sep 08 16:51:54 2004

This archive was generated by hypermail 2.1.8 : Wed 03 Nov 2004 - 22:45:13 EST