[Rd] RE: problem with R CMD build--FIXED (PR#7241)

From: <sego_at_vt.edu>
Date: Tue 21 Sep 2004 - 06:36:22 EST


> I'm puzzled. One thing I'd try would be to get Cygwin out of the picture,
> at least for a moment. Try to set TMPDIR (and maybe TMP and TEMP) to
> C:\Temp,
> and try to run the whole thing from a "DOS" Cmd.exe window.

Here it is:

D:\dirk\bands\implementation>set TMPDIR=d:\tmp

D:\dirk\bands\implementation>echo %TMPDIR% d:\tmp

D:\dirk\bands\implementation>r CMD BUILD --help Usage: R CMD BUILD [options] pkgdirs

Build R packages from package sources in the directories specified by pkgdirs.

Options:

   -h, --help            print short help message and exit
   -v, --version         print version info and exit

   --force               force overwriting of INDEX file
   --no-vignettes        do not rebuild package vignettes

   --binary              build pre-compiled binary packages, with options:
   --docs=TYPE           type(s) of documentation to build and install
   --auto-zip            select zipping of data and help based on size
   --use-zip-data        collect data files in zip archive
   --use-zip-help        collect help and examples into zip archives
   --use-zip             combine '--use-zip-data' and '--use-zip-help'

Email bug reports to <r-bugs@r-project.org>.

So that works. I then right-clicked on "My Computer", then clicked on "Properties", "Advanced", "Environment Variables" and then set new variable called "TMPDIR".

Having done that, "r CMD build" works in Cygwin too.

I wonder why I never saw this before with the previous machine? Well it looks like this one is fixed.

Landon


Landon Sego
Department of Statistics
Virginia Tech
414 Hutcheson
(540) 231-2144



R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Tue Sep 21 06:41:03 2004

This archive was generated by hypermail 2.1.8 : Wed 03 Nov 2004 - 22:45:16 EST