[Rd] doc error for .First.lib

From: Kjetil Brinchmann Halvorsen <kjetil_at_acelerate.com>
Date: Sun 19 Sep 2004 - 12:58:39 EST


The help page of .First.lib in rw2000dev, downloaded a few hours ago, contains:

Packages that require other packages:

     The source code for a package that requires one or more other
     packages should have a call to 'require', preferably near the
     beginning of the source, and of course before any code that uses
     functions, classes or methods from the other package.  The default
     for argument 'save' will save the names of all required packages
     in the environment of the new package.  The saved package names
     are used by 'detach' when a package is detached to warn if other
     packages still require the detached package.  Also, if a package
     is installed with saved image (see INSTALL), the saved package
     names are used to require these packages when the new package is
     attached.

which is contradicted, by the information on the page http://developer.r-project.org/200update.txt

which bans require etc.

Kjetil

-- 

Kjetil Halvorsen.

Peace is the most effective weapon of mass construction.
               --  Mahdi Elmandjra

______________________________________________
R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Thu Oct 21 21:13:31 2004

This archive was generated by hypermail 2.1.8 : Wed 03 Nov 2004 - 22:45:23 EST