[Rd] problems with bitmap images in windows XP

From: Kjetil Brinchmann Halvorsen <kjetil_at_acelerate.com>
Date: Thu 07 Oct 2004 - 00:14:15 EST


This is rw2000 on windowsXP

 jpeg("test.jpeg", bg="orangered")
 plot(1:10, 1:10, col="green")
 dev.off()


jpeg("test.jpeg", bg="blue")
 plot(1:10, 1:10, col="red")
 dev.off()


 jpeg("test.jpeg", bg="green")
 plot(1:10, 1:10, col="red")
 dev.off()

---

jpeg("test.jpeg", bg="white")
 plot(1:10, 1:10, col="red")
 dev.off()

Now, all of this gives a bluish background when wieved with Windows Picture and Fax wiever or with the GIMP-2.0 The bg= argument does not seem to have any effect.

Now repeating in rw191:

jpeg("test.jpeg", bg="orangered")
 plot(1:10, 1:10, col="blue")
 dev.off()

and the background is blue (not the same "bluish" as above)

jpeg("test.jpeg", bg="blue")
 plot(1:10, 1:10, col="red")
 dev.off()

and the background color is red.

Similar symptoms with the other bitmap devices.

The only mention about bitmap devices in the NEWS file for R2.0.0 is

 o The png() and jpeg() devices (and the bmp() device under Windows)

    now allow a nominal resolution to be recorded in the file.

So what has happened?

Kjetil

-- 

Kjetil Halvorsen.

Peace is the most effective weapon of mass construction.
               --  Mahdi Elmandjra

______________________________________________
R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Thu Oct 07 00:21:19 2004

This archive was generated by hypermail 2.1.8 : Fri 18 Mar 2005 - 09:00:27 EST