Re: [Rd] R 2.0.0 - lazy loading mandadory ? (PR#7274)

From: <ligges_at_statistik.uni-dortmund.de>
Date: Sun 10 Oct 2004 - 23:18:38 EST


xiao.gang.fan1@libertysurf.fr wrote:

> Full_Name: Xiao Gang FAN
> Version: R 2.0.0
> OS: Windows
> Submission from: (NULL) (82.226.247.142)
>
>
> When a package preload another necessary package, say Hmisc,
> seems that this last one must be precompiled, this is rather
> boring - we must rebuild all dependant packages ?

  1. This is a question. Questions are ought to be send to R-help BUT NOT TO R-BUGS!
  2. THIS QUESTION IS EVEN NOT APPROPRIATE FOR R-HELP, because the answer is in the News file.

The news file tells us that re*installing* packages is required for R-2.0.0 (rebuilding is not required per se). Yes, ALL packages you are going to use!
And for your convenience, there are precompiled versions available on CRAN.

Uwe Ligges

> Here's an error when compiling such a package:
>
> ---------- Making package toto ------------
> adding build stamp to DESCRIPTION
>
> making DLL ...
>
> ... DLL made
>
> installing DLL
>
> installing R files
>
> installing data files
>
> no man files in this package
>
> installing indices
>
> not zipping data
>
> installing help
>
> preparing package toto for lazy loading
> Error in library(pkg, character.only = TRUE, logical = TRUE, lib.loc = lib.loc)
> :
> 'Hmisc' is not a valid package -- installed < 2.0.0?
>
> Execution halted
>
> make: *** [lazyload] Error 1
>
> *** Installation of toto failed ***
>
> ______________________________________________
> R-devel@stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel



R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Sun Oct 10 23:23:49 2004

This archive was generated by hypermail 2.1.8 : Wed 03 Nov 2004 - 22:45:21 EST