Re: [Rd] strange behaviour in R 2.0.0 (PR#7275)

From: Fan <xiao.gang.fan1_at_libertysurf.fr>
Date: Mon 11 Oct 2004 - 03:45:40 EST

Dear Prof Ripley,

After looking at my original C code, which is different in 2.0.0 should be (sorry, not tested as I've desinstalled 2.0.0, tired of the time wasted):

 > a=list(x=1:2)
 > a$y = strptime(c("20010101","20020101"),"%Y%m%d")
 > a = data.frame(a)
 > rbind(a,a)

For the point 1 in PR#7269 (failure in installing packages from source), I've encountered that for several packages (so "toto" means nothing). I guess that should come from changes somewhere related to the "index" check in the perl script for making process. I agree with you it'd be difficult to claim that a bug, but anyway, it's not expected as I've checkec the different files (man, INDEX, DESCRIPTION) and can't figure out what's wrong, and it WORKS with 1.9.1.

ps: sorry for having posted 2 times (PR#7269, PR#7272), I've used the Web interface of R-Bugs to send the report, and after posting the first one, I've figured out that there was an error in the email address (xiao.gang.fan@libertysurf.fr instead of xiao...1@libertysurf.fr).

--
Fan

Prof Brian Ripley wrote:

> This is the fourth bug report today from Xiao Gang FAN, and we have had no
> response to replies to the first three. Please do not send bug reports
> unless you are prepared to take responsibility for them and answer
> requests for further information.
>
> Please read the posting guide and the FAQ and use a meaningful subject
> line.
>
> Now, where is the requested code to reproduce PR#7272?
>
>
> On Sun, 10 Oct 2004 xiao.gang.fan1@libertysurf.fr wrote:
>
>
>>Full_Name: Xiao Gang FAN >>Version: R 2.0.0 >>OS: Windows >>Submission from: (NULL) (82.226.247.142) >> >> >>The following codes worked for R 1.9.1 >> >> >>>a = data.frame(x=1:2) >>>a$y = strptime(c("20010101","20020101"),"%Y%m%d") >> >>this no longer works for R 2.0.0: >> >>Error in "$<-.data.frame"(`*tmp*`, "y", value = list(sec = c(0, 0), min = c(0, >>: >> replacement has 9 rows, data has 2
>
>
> That code is indeed incorrect, and did fail in 1.9.1:
>
> R : Copyright 2004, The R Foundation for Statistical Computing
> Version 1.9.1 (2004-06-21), ISBN 3-900051-00-3
>
>
>>a = data.frame(x=1:2) >>a$y = strptime(c("20010101","20020101"),"%Y%m%d")
>
> Error in "$<-.data.frame"(`*tmp*`, "y", value = strptime(c("20010101", :
> replacement has 9 rows, data has 2
>
> It even failed in 1.8.0. It `worked' in 1.7.0, but did not do what you
> most likely wanted it to do (see the NEWS for 1.8.0). You cannot sensibly
> add "POSIXlt" objects to a data frame: you can add "POSIXct" objects.
> ______________________________________________ R-devel@stat.math.ethz.ch mailing list https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Mon Oct 11 03:50:40 2004

This archive was generated by hypermail 2.1.8 : Wed 03 Nov 2004 - 22:45:21 EST