[Rd] Re: Bug#275791: r-gnome: gnome library can not be read (PR#7276)

From: <edd_at_debian.org>
Date: Mon 11 Oct 2004 - 10:49:59 EST


Dear R bug fixers,

This came in early this morning. The R/Gnome configuration, and selection of libraries hat not changed one bit since I last built 1.9.1 -- but maybe something change in the Gmome/Glib/Gtk, or even x11, libraries? Would anyone know where RestoreAction is defined?

The list of Debian packages on which r-gnome depends is below; as this is computed from ldd output I won't add that direct ldd output, but would be glad to supply it as well as other information if it could aid in fixing this.

Thanks, Dirk

On Sun, Oct 10, 2004 at 11:41:41AM +0200, Wouter Leonard de Vries wrote:
> Package: r-gnome
> Version: 2.0.0-1
> Severity: grave
> Justification: renders package unusable
>
>
> when trying to start r-gnome I get the following message:
>
> Fatal error: The GNOME shared library could not be loaded.
> The error was /usr/lib/R/modules/R_gnome.so: undefined symbol:
> RestoreAction
>
>
> -- System Information:
> Debian Release: 3.1
> APT prefers unstable
> APT policy: (500, 'unstable'), (1, 'experimental')
> Architecture: i386 (i686)

> Kernel: Linux 2.6.8.1

> Locale: LANG=nl_NL, LC_CTYPE=nl_NL
>
> Versions of packages r-gnome depends on:
> ii gdk-imlib1 1.9.14-16 imaging library for use with gtk (
> ii libart2 1.4.2-19 The GNOME canvas widget - runtime
> ii libaudiofile0 0.2.6-4 Open-source version of SGI's audio
> ii libbz2-1.0 1.0.2-1 A high-quality block-sorting file
> ii libc6 2.3.2.ds1-17 GNU C Library: Shared libraries an
> ii libdb3 3.2.9-20 Berkeley v3 Database Libraries [ru
> ii libesd0 0.2.34-1 Enlightened Sound Daemon - Shared
> ii libglade-gnome0 1:0.17-3 Library to load .glade files at ru
> ii libglade0 1:0.17-3 Library to load .glade files at ru
> ii libglib1.2 1.2.10-9 The GLib library of C routines
> ii libgnome32 1.4.2-19 The GNOME libraries
> ii libgnomesupport0 1.4.2-19 The GNOME libraries (Support libra
> ii libgnomeui32 1.4.2-19 The GNOME libraries (User Interfac
> ii libgtk1.2 1.2.10-17 The GIMP Toolkit set of widgets fo
> ii libice6 4.3.0.dfsg.1-8 Inter-Client Exchange library
> ii libncurses5 5.4-4 Shared libraries for terminal hand
> ii libpcre3 4.5-1.1 Perl 5 Compatible Regular Expressi
> ii libreadline4 4.3-13 GNU readline and history libraries
> ii libsm6 4.3.0.dfsg.1-8 X Window System Session Management
> ii libx11-6 4.3.0.dfsg.1-8 X Window System protocol client li
> ii libxext6 4.3.0.dfsg.1-8 X Window System miscellaneous exte
> ii libxi6 4.3.0.dfsg.1-8 X Window System Input extension li
> ii libxml1 1:1.8.17-8 GNOME XML library
> ii r-base-core 2.0.0-1 GNU R core of statistical computin
> ii xlibs 4.3.0.dfsg.1-8 X Window System client libraries m
> ii zlib1g 1:1.2.2-1 compression library - runtime
>
> -- no debconf information

-- 
Those are my principles, and if you don't like them... well, I have others.
                                                -- Groucho Marx

______________________________________________
R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Mon Oct 11 10:55:13 2004

This archive was generated by hypermail 2.1.8 : Fri 18 Mar 2005 - 09:00:32 EST