Re: (PR#7277) Re: [Rd] strange windows behaviour after changing

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Tue 12 Oct 2004 - 22:41:48 EST


I've got a lot further.

  1. The problem is due to changing the console font, which the preference dialog always did (even if it changed it to a new copy of the same font).
  2. It is associated with MDI toolbars, and never happens if they are not selected. I found one inconsistency: you (I think) have added pager toolbar buttons and not added setdata() statements, but that does not fix it. I can also trigger it by opening a graphics windows or a script window, but I did not succeed with a dataentry window.

It looks like something is wrong with the toolbar code, which Guido wrote as a GraphApp extension and I have not much understanding of.

On Tue, 12 Oct 2004, Duncan Murdoch wrote:

> I still don't see it. This is strange -- I'm also using XP SP2.
>
> Duncan Murdoch
>
> On Tue, 12 Oct 2004 09:55:55 +0200 (CEST), ripley@stats.ox.ac.uk
> wrote:
>
> >I can reproduce this in MDI. Another clue is that as the pager for
> >?merge is opened, the font in the console changes.

That happens as the toolbar is changed to that for a pager.

> >The console is still working: commands you type in it are accepted.
> >So the issue appears to be that the font in use has been changed
> >incorrectly (and it seems that the C code thinks it has been changed in
> >the preferences dialog).
> >
> >
> >On Tue, 12 Oct 2004, Duncan Mackay wrote:
> >
> >> Hello,
> >> Thanks for your reply. Yes, editing Rconsole worked (problem didn't appear
> >> under MDI with lines=16000) after start-up.
> >> Simply shrinking and restoring the windows didn't restore functionality - my
> >> R console window remained blank and unresponsive (even to Esc's) so I had to
> >> shut down R. I was using the MDI interface and my computer is a Toshiba
> >> Satellite A10 laptop.
> >> I've just tried editing the Rconsole to switch to SDI, and the problems
> >> didn't appear under SDI.
> >> Thanks, Duncan
> >>
> >>
> >>
> >>
> >> -----Original Message-----
> >> From: Prof Brian Ripley [mailto:ripley@stats.ox.ac.uk]
> >> Sent: Monday, 11 October 2004 6:04 PM
> >> To: duncan.mackay@flinders.edu.au
> >> Cc: R-bugs@biostat.ku.dk; r-devel@stat.math.ethz.ch
> >> Subject: Re: (PR#7277) Re: [Rd] strange windows behaviour after changing
> >> "lines" GUI setting (PR#7277)
> >>
> >>
> >> On Mon, 11 Oct 2004, Prof Brian Ripley wrote:
> >>
> >> > Doesn't happen for me (on two rather different machines under Windows
> >> > XP SP2). This looks like a Windows GDI refresh problem. Does editing
> >> > the Rconsole file work? If so, that is a usable workaround. Does
> >> > minimizing and restoring the windows show the correct contents?
> >>
> >> One more thing: was this the MDI or SDI interface? I only tested SDI.
> >>
> >> > On Mon, 11 Oct 2004 duncan.mackay@flinders.edu.au wrote:
> >> >
> >> > > Full_Name: Duncan Mackay
> >> > > Version: 2.0.0
> >> > > OS: WinXP
> >> > > Submission from: (NULL) (129.96.120.254)
> >> > >
> >> > >
> >> > > > version
> >> > > _
> >> > > platform i386-pc-mingw32
> >> > > arch i386
> >> > > os mingw32
> >> > > system i386, mingw32
> >> > > status
> >> > > major 2
> >> > > minor 0.0
> >> > > year 2004
> >> > > month 10
> >> > > day 04
> >> > > language R
> >> > >
> >> > > I am running the above version of R under WinXP Service Pack 2.
> >> > >
> >> > > I have encountered some strange behaviour after changing the "lines"
> >> > > setting in the GUI preferences, as follows:-
> >> > >
> >> > > "Select Edit/GUI preferences..."
> >> > > Change the "lines" setting from 8000 to 16000
> >> > > Click "Apply" then "OK"
> >> > > Back at the R console, type ?merge
> >> > >
> >> > > The "R Help on 'merge'" window appears but is blank???????
> >> > >
> >> > > Click back in the R Console window. Now it goes blank ???????????
> >> > >
> >> > > ______________________________________________
> >> > > R-devel@stat.math.ethz.ch mailing list
> >> > > https://stat.ethz.ch/mailman/listinfo/r-devel
> >> > >
> >> > >
> >> >
> >> >
> >>
> >>
>
>

-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Tue Oct 12 22:47:02 2004

This archive was generated by hypermail 2.1.8 : Wed 03 Nov 2004 - 22:45:21 EST