[Rd] need help debugging on Windows

From: Liaw, Andy <andy_liaw_at_merck.com>
Date: Tue 26 Oct 2004 - 12:26:35 EST


Dear R-devel,

Apologies for bothering y'all with this seemingly perennial question. A user reported problem with my most recent version of randomForest (4.4-1), and I was able to reproduce it with his data with R-2.0.0 patched (2004-10-24) on WinXP Pro. The problem is that it crashes R on Windows. However, it does not happen on Linux (tried SUSE ES8 on our Opterons and Quantian on my laptop). On Linux, the memory usage for the R process goes up to about 130MB and stays there. On Windows, the memory usage would increase as the number of trees are grown (which already seem strange, as no more memory allocation is being done as the trees are grown), reaches about 130MB, then starts to decline, and eventually crashes the Rgui (or Rterm) process.

My biggest problem is that I have not been able to get gdb to work under WinXPPro, thus I've been relying on Linux for debugging. This time I'm really baffled, as the problem does not appear on Linux. Can anyone provide any hint/pointer? I (and my hair) will be very, very grateful!

Best,
Andy

Andy Liaw, PhD

Biometrics Research      PO Box 2000, RY33-300     
Merck Research Labs           Rahway, NJ 07065
mailto:andy_liaw@merck.com        732-594-0820

______________________________________________
R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Tue Oct 26 12:33:55 2004

This archive was generated by hypermail 2.1.8 : Fri 18 Mar 2005 - 09:00:56 EST