[Rd] Buglet in install.packages warning message

From: Seth Falcon <sfalcon_at_fhcrc.org>
Date: Mon 21 Mar 2005 - 02:34:13 GMT


I've been experimenting with install.packages and it's new ability to track down dependencies from a list of repositories and encountered this:

install.packages(c("foo", "bar"), repos="http://cran.r-project.org",

                 dependencies=c("Depends", "Suggests"))

dependencies 'foo' are not availabledependencies 'bar' are not available
                           ^^^^^^^^^^^^^^^^^^^^

With the following change (see below) I get what I suspect is the intended warning message:

   dependencies 'foo', 'bar' are not available

+ seth

Index: packages2.R



R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Mon Mar 21 13:37:20 2005

This archive was generated by hypermail 2.1.8 : Mon 20 Feb 2006 - 03:21:02 GMT