Re: [Rd] RGUI font problem (PR#7749)

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Sat 26 Mar 2005 - 07:24:29 GMT

This would appear to be the same as PR#7277. That too is not really reproducible.

One possible crucial piece of missing information: is RGui being run in SDi or MDI mode?

On Sat, 26 Mar 2005 christos@nuverabio.com wrote:

> Full_Name: Christos Hatzis
> Version: 2.0.1 patched (2005-02-18)
> OS: WinXP SP2
> Submission from: (NULL) (24.61.19.101)
>
>
> I had encountered a similar problem when changing the font in the R Console and
> then then open the graphics device by plot(), the console window whites out.
> this might be related to bug report 7271. I mentioned it sometime back and was
> told is was not reproducible.
>
> Now I have encountered a similar problem that does not appear to relate to the
> graphics device. I started an R session, changed the font to size 8, Apply/OK.
> Then I opened a help page by typing
>> ?plot
> the R help page opened in a different (system?) font and the font in the console
> also changed to the same bold-face, non-proportional font. Then when I typed
> another help command, the console completely blanked out.

It is almost certainly not blank, just using the wrong foreground colour.

> There seems to be some strange interaction going on between new windows opened
> by the system and the font setting in the GUI preferences.

Yes, and that is PR#7277.

-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Sat Mar 26 18:29:23 2005

This archive was generated by hypermail 2.1.8 : Mon 20 Feb 2006 - 03:21:02 GMT