[Rd] install.packages in R 2.2.0

From: Iago Mosqueira <imosqueira_at_suk.azti.es>
Date: Tue 22 Nov 2005 - 16:19:57 GMT


Dear all,

I am having trouble with install.packages() when specifying a non-CRAN repository. The command below works in R 2.1.0 and R 2.1.1 compiled from source in Linux, bringing up the Tcl/Tk interface for selection, but in 2.2.0 I get

> install.packages(repos='http://flr-project.org/R')
Error in install.packages(repos = "http://flr-project.org/R") :

        argument "pkgs" is missing, with no default In addition: Warning message:
number of rows of result

        is not a multiple of vector length (arg 2) in: cbind(1, res0, Repository = repos)

Has there been any change to this function, or the way repositories should be organised, that I have missed in the NEWS file?

For example, a package file called FLCore_1.0.7.tar.gz is located in http://flr-project/R/src/contrib/ and the relevant entry in the PCAKGEs file looks like this:

Package: FLCore
Version: 1.0.7
Depends: R (>=2.2.0), methods, graphics, stats, lattice

but install.packages from R 2.2.0 is not getting to it.

In contrast, The FLCore_1.0.3.3.tar.gz file, with entry

Package: FLCore
Version: 1.0.3.3
Depends: R (>=2.1.0), methods, graphics, stats, lattice

gets picked up when install.packages is called from R 2.1.1. There are other packages in this repository that do not have versions dependent on R version, but still the same problem appears.

Any ideas? Thanks very much,

Iago Mosqueira



R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Wed Nov 23 03:26:48 2005

This archive was generated by hypermail 2.1.8 : Tue 22 Nov 2005 - 21:21:44 GMT