Bug in "[.ts" for multivariate ts {Problem with plot.ts, "["} (PR#216)

About this list Date view Thread view Subject view Author view Other groups

Subject: Bug in "[.ts" for multivariate ts {Problem with plot.ts, "["} (PR#216)
maechler@stat.math.ethz.ch
Date: Sat 03 Jul 1999 - 02:44:18 EST


Message-Id: <199907021644.SAA21974@pubhealth.ku.dk>

>>>>> On Fri, 02 Jul 1999, Adrian Trapletti <Adrian.Trapletti@wu-wien.ac.at> said:

Adrian> There seems to be a problem with plot.ts (R Version 0.64.2)
> x<-cbind(1:10,2:11)
> x<-as.ts(x)
> plot(x)
Adrian> Error: subscript (20) out of bounds, should be at most 10

This is definitely a bug
--> CC: R-bugs

ALL NOTE : This is *not* new in 0.64.2

Adrian> The problem is located in "[.ts":

> x<-cbind(1:10,2:11)
> x[is.finite(x)]
Adrian> [1] 1 2 3 4 5 6 7 8 9 10 2 3 4 5 6 7 8 9 10 11
> x<-as.ts(x)
> x[is.finite(x)]
Adrian> Error: subscript (20) out of bounds, should be at most 10

Adrian> and there (in "[.ts") the following statement gives the error:

Adrian> Browse[1]>
Adrian> debug: li <- length(ind <- (1:n)[i])

Adrian> However I don't understand what this part exactly does?

-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !) To: r-devel-request@stat.math.ethz.ch
_._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._


About this list Date view Thread view Subject view Author view Other groups

This archive was generated by hypermail 2b25 : Tue 04 Jan 2000 - 14:16:05 EST