Re: [R] R --gnome segfaults on RH 6.0 with R-0.65.0

About this list Date view Thread view Subject view Author view Other groups

Subject: Re: [R] R --gnome segfaults on RH 6.0 with R-0.65.0
From: Alexander Volovics (awol@xs4all.nl)
Date: Wed 01 Sep 1999 - 07:21:31 EST


Message-ID: <XFMail.990831232131.awol@xs4all.nl>

On 31-Aug-99 Peter Dalgaard BSA wrote:

> What would interest me is what the content of R_gnome_userprefs.font
> if you go up to #40 (in R_gtk_terminal_new () at terminal.c:112). Just
> type
> p R_gnome_userprefs.font
> if it's NULL, then we might have a lead on the problem. But Lyndon
> Drake is the guy who knows his way around the Gnome stuff, not me.

Here is the result:

#40 0x80cd79b in R_gtk_terminal_new () at terminal.c:112
112 gtk_widget_show_all(R_gtk_main_window);
(gdb) p R_gnome_userprefs.font
$1 = (gchar *) 0x814cbf0 ""

> What is in your .gnome/R.gnome file, by the way?

Here is my R.gnome:

[Placement]
Dock=Toolbar\\0,1,0,0\\Menubar\\0,0,0,0

[Text]
textcolor=rgb:0000/0000/0000
bgcolor=rgb:ffff/ffff/ffff
font=

[Pager]
title_font=-adobe-helvetica-bold-r-normal-*-*-100-*-*-p-*-iso8859-1
title_textcolor=rgb:0000/0000/0000
title_bgcolor=rgb:ffff/ffff/ffff
text_font=-misc-fixed-medium-r-normal-*-*-120-*-*-c-*-iso8859-1
em_font=-misc-fixed-bold-r-normal-*-*-120-*-*-c-*-iso8859-1
text_textcolor=rgb:0000/0000/0000
text_bgcolor=rgb:ffff/ffff/ffff

HA. The solution is often very simple. I should have thought of
looking here myself. Under [Text] there is no entry for font!
Enter a font and R.gnome works.

This means that it would also have worked with libglade-0.3-1.
Is this an ommision in configure/make/make install?

Thanks for taking the time to respond and the suggestions.

*************************************
Alexander Volovics
Dept of Methodology & Statistics
Maastricht University, Maastricht, NL
*************************************

-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !) To: r-devel-request@stat.math.ethz.ch
_._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._


About this list Date view Thread view Subject view Author view Other groups

This archive was generated by hypermail 2b25 : Tue 04 Jan 2000 - 14:16:07 EST