problem in R.sh.in script (PR#272)

About this list Date view Thread view Subject view Author view Other groups

Subject: problem in R.sh.in script (PR#272)
oka@debian.or.jp
Date: Fri 10 Sep 1999 - 16:53:40 EST


Message-Id: <199909100653.IAA02811@pubhealth.ku.dk>

I found problem in R-0.65.0/src/scripts/R.sh.in script.
When I run R program with `R -d gdb', R script say,

  /usr/local/bin/R[104]: shift: bad number

I fixed this problem by applying following patch to the script:

*** R.sh.in.orig Fri Sep 10 13:01:10 1999
--- R.sh.in Fri Sep 10 13:01:23 1999
***************
*** 48,54 ****
      -g|--gnome)
        R_BINARY="R.gnome" ;;
      -d|--debugger)
! DBG="${2}"; shift 2 ;;
      --no-environ)
        USE_R_ENVIRON=false ;;
      --vanilla)
--- 48,54 ----
      -g|--gnome)
        R_BINARY="R.gnome" ;;
      -d|--debugger)
! DBG="${2}"; shift ;;
      --no-environ)
        USE_R_ENVIRON=false ;;
      --vanilla)

--please do not edit the information below--

Version:
 platform = i586-unknown-linux
 arch = i586
 os = linux
 system = i586, linux
 status =
 status.rev = 0
 major = 0
 minor = 65.0
 year = 1999
 month = August
 day = 27
 language = R

Search Path:
 .GlobalEnv, Autoloads, package:base

-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !) To: r-devel-request@stat.math.ethz.ch
_._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._


About this list Date view Thread view Subject view Author view Other groups

This archive was generated by hypermail 2b25 : Tue 04 Jan 2000 - 14:16:08 EST