Re: [R] problems with postscript device (PR#336)

About this list Date view Thread view Subject view Author view Other groups

Subject: Re: [R] problems with postscript device (PR#336)
maechler@stat.math.ethz.ch
Date: Wed 24 Nov 1999 - 01:48:04 EST


Message-Id: <199911231548.QAA26178@pubhealth.ku.dk>

>>>>> "WoKo" == Wolfgang Koller <koller2@fgr.wu-wien.ac.at> writes:

WoKo> Hi! The postscript device in 0.90 does not produce symbols
WoKo> (pch=) as it should. E.g.:

WoKo> postscript(file="test.ps",width=8,height=6.4,horizontal=FALSE)
WoKo> plot(1:10,1:10,pch=1:5)
WoKo> legend(1,9,letters[1:5],pch=1:5)
WoKo> dev.off()

WoKo> The result looks quite different compared to the X-windows
WoKo> version. The symbol 1 (pch=1) is much to small, while the other
WoKo> symbols seem to big.

WoKo> Is it a bug?
yes, definitely.
there's a second (less severe) bug, too :

The second symbol (triangle)
is \Delta /\ on x11 (and postscript in R <= 0.65)
          -- __
but is \Lambda \/ for postscript in R 0.90.0..

WoKo> How can I work it around?

as you said: by not using pch=1.... :-)
a patch will probably appear "soon"...

Martin Maechler <maechler@stat.math.ethz.ch> http://stat.ethz.ch/~maechler/
Seminar fuer Statistik, ETH-Zentrum LEO D10 Leonhardstr. 27
ETH (Federal Inst. Technology) 8092 Zurich SWITZERLAND
phone: x-41-1-632-3408 fax: ...-1228 <><

-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !) To: r-devel-request@stat.math.ethz.ch
_._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._


About this list Date view Thread view Subject view Author view Other groups

This archive was generated by hypermail 2b25 : Tue 04 Jan 2000 - 14:16:10 EST