[R] No graphics capability on fresh install of R2.11.0 on FreeBSD 8.0

From: Ben Madin <lists_at_remoteinformation.com.au>
Date: Thu, 17 Jun 2010 10:45:35 +0800

G'day all,

I am working on a new FreeBSD 8.0 Server (remotely located), and have installed (now several times) R 2.11.0 but I cannot get any graphic outputs (everything else seems to be happening fine...)

During install I have noticed and checked that png, jpeg, cairo etc libraries are available - here is the build output :

R is now configured for amd64-portbld-freebsd8.0

 Source directory: .
 Installation directory: /usr/local

 C compiler:                gcc44 -std=gnu99  -O2 -pipe -Wl,-rpath=/usr/local/lib/gcc44 -fno-strict-aliasing
 Fortran 77 compiler:       gfortran44  -O

 C++ compiler:              g++44  -O2 -pipe -Wl,-rpath=/usr/local/lib/gcc44 -fno-strict-aliasing
 Fortran 90/95 compiler:    gfortran44 -O
 Obj-C compiler:	     gcc -g -O2

 Interfaces supported:      X11, tcltk
 External libraries:        readline, BLAS(generic), LAPACK(generic), ICU, lzma
 Additional capabilities:   PNG, JPEG, TIFF, NLS, cairo
 Options enabled:           shared R library, R profiling

 Recommended packages:      yes

===> Building for R-2.11.0_1

and thus

> sessionInfo()

R version 2.11.0 (2010-04-22)
amd64-portbld-freebsd8.0

locale:
[1] C

attached base packages:
[1] stats graphics grDevices utils datasets methods base

other attached packages:
[1] Cairo_1.4-6

yet when I start it up, I get this :

> library(graphics)
> png('this.file.png')

Error in X11(paste("png::", filename, sep = ""), width, height, pointsize, :   unable to start device PNG
In addition: Warning message:

In png("this.file.png") : unable to open connection to X11 display ''

and after installing Cairo

> install.packages('Cairo',,'http://www.rforge.net/')
  trying URL 'http://www.rforge.net/src/contrib/Cairo_1.4-6.tar.gz'

I get :

> library(Cairo)
> Cairo(file='thisfile.png', type='png', height=480, width=640)
Error in Cairo(file = "thisfile.png", type = "png", height = 480, width = 640) :   No font found in Rcairo_set_font

Thus stumped, I checked :

> capabilities()

    jpeg      png     tiff    tcltk      X11     aqua http/ftp  sockets 
   FALSE    FALSE    FALSE     TRUE    FALSE    FALSE     TRUE     TRUE 
  libxml     fifo   cledit    iconv      NLS  profmem    cairo 
    TRUE     TRUE     TRUE     TRUE     TRUE    FALSE    FALSE 

If this is not the appropriate place for this to be sorted, I am happy to try elsewhere.

cheers

Ben



R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Thu 17 Jun 2010 - 02:49:24 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Fri 18 Jun 2010 - 06:40:33 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive