[R] Problem calling R from within perl script on Windows

From: Barry Hall <barryhall_at_zeninternet.com>
Date: Fri, 18 Jun 2010 12:11:53 -0700 (PDT)

I need to call R from within a Perl script. I do so using a system call like this:
@args = ('R --vanilla --quiet --file=Rblock');
system(@args) == 0 or die "system @args failed: $!";

The script works perfectly when run in Mac OSX or Linux. In Windows XP it fails with the message " 'R' is not recognized as an internal or external command, operable program or batch file".

To ensure that R was properly installed and that the environment variable "path" was correctly set, I executed the same command (R --vanilla --quiet --file=Rblock) from the command line and it worked perfectly; i.e. R ran with the expected behavior.

Similar system calls to other external programs, e.g.
@args = ('Notepad');

system(@args) == 0 or die "system @args failed: $!"; work perfectly.

Is there any obvious reason that this particular call works from the command line but not from within a perl script?

Thanks for any assistance

-- 
View this message in context: http://r.789695.n4.nabble.com/Problem-calling-R-from-within-perl-script-on-Windows-tp2260646p2260646.html
Sent from the R help mailing list archive at Nabble.com.

______________________________________________
R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Received on Fri 18 Jun 2010 - 20:51:16 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Sat 19 Jun 2010 - 09:00:34 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive