Re: [Rd] Package RPostgreSQL_0.1-6.tar.gz has been checked and built

From: Amber <guxiaobo1982_at_gmail.com>
Date: Wed, 21 Jul 2010 16:43:28 +0800

Thanks Professor Brain Ripley and Dirk,

I have successfully INSTALLED RPostgreSQL on Solaris 10 update 7 i386 64bit version. The detailed procedure is as following: 1. Delete the preinstalled 8.1.11 packagegs, which are all 32 bit. 2. Add /usr/postgres/8.3/bin/amd64 to PATH so that configure can find the 64bit pg_config
3. Add /usr/postgres/8.3/lib/amd64 to LD_LIBRARY_PATH as you mentioned.

Now I can connect to Greenplum SNE 3.3.5.0 backend and use dbGetQuery fetching data.

Xiaobo Gu

On Wed, Jul 21, 2010 at 3:04 PM, Prof Brian Ripley <ripley_at_stats.ox.ac.uk>wrote:

> AFAIK, you simply need to put the path to the correct pg_config first in
> your path -- depending how the PostgreSQL installation was done you may also
> need to ensure that its libraries are in your LD_LIBRARY_PATH.
>
> Given that this is the third query you have sent to the R lists about
> contributed packages, I think you should consider if you really need 64-bit
> R. 32-bit R is simpler to get working on most platforms, including Solaris,
> especially with external software. I am presuming (from the 'bin/amd64')
> that this is an Opteron/Xeon system, and there 64-bit software is
> problematic simply because gcc does not seem to work well. (Most often the
> 'particular errors' are not with Solaris but with non-standard conformant
> code written assuming gcc extensions or laxities -- for which the fix is
> often to use gcc.)
>
> And BTW, you keep on saying 'Solaris 10u7 X64' and I've no idea what that
> is. The 'at a minimum' information asked for in the posting guide will give
> a correct description. Solaris has come for many years as a 32/64-bit OS,
> and there is i386 Solaris and Sparc Solaris.
>
>
> On Wed, 21 Jul 2010, Amber wrote:
>
> Hi Dirk
>>
>> I think there are problems with pg_config, the configure script of
>> RPostgreSQL checks for pg_config and got ??checking for pg_config...
>> /usr/bin/pg_config??. In Solaris 10u7 X64, three versions of PostgreSQL
>> are
>> installed, there are in /usr/postgres/8.2(8.2.9) and
>> /usr/postgres/8.3(8.3.3), the corresponding bin files are in
>> /usr/postgres/<version>/bin and /usr/postgres/<version>/bin/amd64, and the
>> libraries in /usr/bin is 8.1.11 and it seems a 32bit one, and I can??t
>> find
>> the 64bit version bins for 8.1.11.
>> I'll try uninstall 8.1.11 and install 8.2.9, and my question is how to let
>> RPostgreSQL configure script find the 64bit pg_config.
>>
>>
>> Xiaobo Gu
>>
>> On Tue, Jul 20, 2010 at 10:32 PM, ?????? <guxiaobo1982_at_gmail.com> wrote:
>>
>> Hi Dirk,
>>>
>>> I think this discussion should help :
>>>
>>> http://stackoverflow.com/questions/1836333/how-can-i-compile-64-bit-postgres-bindings-for-perl-on-solaris
>>> ,
>>> are there environment variables I can set to point to 64bit libraries, or
>>> I
>>> can set the 64bit libraries path /usr/local/psql/lib before /usr/lib,
>>> I'll
>>> let you know the results tomorrow.
>>>
>>>
>>>
>>>
>>>
>>> Xiaobo.Gu
>>>
>>> -----Original Message-----
>>> From: Dirk Eddelbuettel [mailto:edd_at_debian.org]
>>> Sent: Tuesday, July 20, 2010 7:11 PM
>>> To: Amber
>>> Cc: Dirk Eddelbuettel; Uwe Ligges
>>> Subject: Re: Package RPostgreSQL_0.1-6.tar.gz has been checked and built
>>>
>>>
>>> Hi Amber,
>>>
>>> I'm at the useR conference with imperfect connectivity adn can't help
>>> much.
>>> I
>>> also noticed that Solaris often comes up with particular errors -- see
>>> Prof
>>> Ripley's response to your Rattle query.
>>>
>>> RPostgresql may be easy to get built, but you may have to adapt
>>> configure.in.
>>>
>>> On 20 July 2010 at 14:08, Amber wrote:
>>> | Hi Dirk,
>>> | There are problems building RPostgreSQL on 64bit solaris,
>>> | The server has preinstalled PostgreSQL 8.1 client and server binaries ,
>>> and
>>> | we also installed Greenplum SNE 3.3.5.0 server and client installed,
>>> but
>>> the
>>> | postgres user, which I used to build R and RPostgreSQL can't see
>>> Greenplum
>>> | binaries, the error messages are:
>>> |
>>> | -bash-3.00$ R CMD INSTALL RPostgreSQL
>>> | * installing to library '/opt/R/R2-11-1/lib/R/library'
>>> | * installing *source* package 'RPostgreSQL' ...
>>> | checking for gcc... /opt/sunstudio12.1/bin/cc -m64
>>> | checking for C compiler default output file name... a.out
>>> | checking whether the C compiler works... yes
>>> | checking whether we are cross compiling... no
>>> | checking for suffix of executables...
>>> | checking for suffix of object files... o
>>> | checking whether we are using the GNU C compiler... no
>>> | checking whether /opt/sunstudio12.1/bin/cc -m64 accepts -g... yes
>>> | checking for /opt/sunstudio12.1/bin/cc -m64 option to accept ISO C89...
>>> none
>>> | needed
>>> | checking for pg_config... /usr/bin/pg_config
>>> | checking for "/usr/include/pgsql/libpq-fe.h"... yes
>>>
>>> Good!
>>>
>>> | configure: creating ./config.status
>>> | config.status: creating src/Makevars
>>> | ** libs
>>> | /opt/sunstudio12.1/bin/cc -m64 -xc99=all -G -L/opt/R/R2-11-1/lib
>>> | -L/usr/sfw/lib/amd64 -L/usr/lib/amd64 -L/opt/sfw/lib -o RPostgreSQL.so
>>> | RS-DBI.o RS-PostgreSQL.o -L/usr/lib -lpq
>>> | ld: fatal: file /usr/lib/libpq.so: wrong ELF class: ELFCLASS32
>>> | ld: fatal: File processing errors. No output written to RPostgreSQL.so
>>>
>>> The linker complained about bad objkect files. Looks like you have a
>>> wrong
>>> or
>>> mismatched Pg library. We'd have to fix that first before RPostgreSQL
>>> can
>>> be
>>> built.
>>>
>>> Also ask Greenplum if they can help. At least they get paid for this :)
>>>
>>> Dirk
>>>
>>> | *** Error code 1
>>> | The following command caused the error:
>>> | if test "zRS-DBI.o RS-PostgreSQL.o" != "z"; then \
>>> | echo /opt/sunstudio12.1/bin/cc -m64 -xc99=all -G -L/opt/R/R2-11-1/lib
>>> | -L/usr/sfw/lib/amd64 -L/usr/lib/amd64 -L/opt/sfw/lib -o RPostgreSQL.so
>>> | RS-DBI.o RS-PostgreSQL.o -L/usr/lib -lpq ; \
>>> | /opt/sunstudio12.1/bin/cc -m64 -xc99=all -G -L/opt/R/R2-11-1/lib
>>> | -L/usr/sfw/lib/amd64 -L/usr/lib/amd64 -L/opt/sfw/lib -o RPostgreSQL.so
>>> | RS-DBI.o RS-PostgreSQL.o -L/usr/lib -lpq ; \
>>> | fi
>>> | make: Fatal error: Command failed for target `RPostgreSQL.so'
>>> | ERROR: compilation failed for package 'RPostgreSQL'
>>> | * removing '/opt/R/R2-11-1/lib/R/library/RPostgreSQL
>>> |
>>> | On Sun, Jul 18, 2010 at 10:50 PM, ?????? <guxiaobo1982_at_gmail.com>
>>> wrote:
>>> |
>>> | > Hi,
>>> | > I have successfully built and installed DBI and RPostgreSQL on
>>> 32bit
>>> | > Solaris, and will repeat in on our 64bit production server tomorrow,
>>> I'll
>>> | > let you know the results.
>>> | >
>>> | > We still waiting for the building toolset for win64 to mature.
>>> | >
>>> | > Xiaobo.Gu
>>> | >
>>> | >
>>> | > -----Original Message-----
>>> | > From: Dirk Eddelbuettel [mailto:edd_at_debian.org]
>>> | > Sent: Sunday, July 18, 2010 9:59 PM
>>> | > To: ??????
>>> | > Cc: 'Dirk Eddelbuettel'; 'Uwe Ligges'
>>> | > Subject: RE: Package RPostgreSQL_0.1-6.tar.gz has been checked and
>>> built
>>> | >
>>> | >
>>> | > Hi again,
>>> | >
>>> | > On 18 July 2010 at 21:41, ?????? wrote:
>>> | > | Hi Dirk,
>>> | > | We have tested RPostgreSQL against 64bit RODBC both on the
>>> same
>>> | > 64bit Windows Server.
>>> | > |
>>> | > | The Environments are as following:
>>> | > |
>>> | > | Case 1: 32bit R 2.11.1, 32bit RPostgreSQL,
>>> | > | data <- dbGetQuery(con, "select * from optest.colana limit 50000")
>>> | > | It takes about 1.5 minute to run
>>> | > |
>>> | > | Case2: 64bit R 2.11.1, 64bit RODBC, and 64bit DataDirect ODBC to
>>> | > Greenplum
>>> | > | data <- sqlQuery(con, "select * from optest.colana limit 50000")
>>> | > | It runs for at least 10 minutes and still running when I kill the
>>> whole R
>>> | > process
>>> | >
>>> | > That's pretty shocking!
>>> | >
>>> | > | It yields out that RPostgres have great performance advantages, we
>>> will
>>> | > try to build RPostgreSQL on 64bit Solaris 10 u7 platform next.
>>> | >
>>> | > Keeping the comparison 'apples to apples' could you build Postgresql
>>> on
>>> | > Windows 64, so that you could build RPostgreSQL against it?
>>> | >
>>> | > Dirk
>>> | >
>>> | > | Xiaobo.Gu
>>> | > |
>>> | > | -----Original Message-----
>>> | > | From: Dirk Eddelbuettel [mailto:edd_at_debian.org]
>>> | > | Sent: Monday, June 28, 2010 11:34 PM
>>> | > | To: Uwe Ligges
>>> | > | Cc: edd_at_debian.org; ?????????3??
>>> | > | Subject: Re: Package RPostgreSQL_0.1-6.tar.gz has been checked and
>>> built
>>> | > |
>>> | > |
>>> | > | Uwe,
>>> | > |
>>> | > | On 28 June 2010 at 16:57, Uwe Ligges wrote:
>>> | > | | Dirk,
>>> | > | |
>>> | > | | da ist derzeit kein 64-bit PostgreSQL auf winbuilder.
>>> | > |
>>> | > | I know that -- but it wasn't me but someone who really badly wants
>>> this
>>> | > on
>>> | > | Windows and is seemingly in several threads on the R lists as well
>>> as
>>> in
>>> | > my
>>> | > | inbox and who didn't edit the DESCRIPTION file before uploading
>>> this.
>>> | > |
>>> | > | Tschoe, Dirk
>>> | > |
>>> | > | |
>>> | > | | Gruss,
>>> | > | | Uwe
>>> | > | |
>>> | > | |
>>> | > | |
>>> | > | | On 28.06.2010 16:36, Uwe.Ligges_at_R-Project.org wrote:
>>> | > | | > Dear package maintainer,
>>> | > | | >
>>> | > | | > this notification has been generated automatically.
>>> | > | | > Your package RPostgreSQL_0.1-6.tar.gz has been built (if
>>> working)
>>> and
>>> | > checked for Windows.
>>> | > | | > Please check the log files and (if working) the binary package
>>> at:
>>> | > | | > http://win-builder.r-project.org/HLQti73j3Y90
>>> | > | | > The files will be removed after roughly 72 hours.
>>> | > | | > Installation time in seconds: 2
>>> | > | | > Check time in seconds: 43
>>> | > | | > Check result: ERROR
>>> | > | | > R version 2.11.1 (2010-05-31) (64-bit)
>>> | > | | >
>>> | > | | > All the best,
>>> | > | | > Uwe Ligges
>>> | > | | > (CRAN maintainer of binary packages for Windows)
>>> | > | | >
>>> | > |
>>> | > | --
>>> | > | Regards, Dirk
>>> | > |
>>> | >
>>> | > --
>>> | > Regards, Dirk
>>> | >
>>> | >
>>>
>>> --
>>> Dirk Eddelbuettel | edd@debian.org | http://dirk.eddelbuettel.com
>>>
>>>
>>>
>> [[alternative HTML version deleted]]
>>
>>
>>
> --
> Brian D. Ripley, ripley_at_stats.ox.ac.uk
> Professor of Applied Statistics, http://www.stats.ox.ac.uk/~ripley/
> University of Oxford, Tel: +44 1865 272861 (self)
> 1 South Parks Road, +44 1865 272866 (PA)
> Oxford OX1 3TG, UK Fax: +44 1865 272595
>

        [[alternative HTML version deleted]]



R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Wed 21 Jul 2010 - 08:45:22 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Wed 21 Jul 2010 - 09:40:17 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive