[Rd] tools::checkRd() output different from R CMD check

From: Dan Tenenbaum <dtenenba_at_fhcrc.org>
Date: Wed, 16 Mar 2011 13:35:25 -0700


Hello,

When running tools::checkRd() on a single .Rd file, should I expect the output to be the same as that generated by R CMD check when it checks .Rd files?

R CMD check finds the following warning:

That warning is in the file man/ilm.Rd.
When I check that file in R, it returns no output:

> library(tools)
> tools::checkRd("ilm.Rd")
>

I'm running the same R in both cases.

> sessionInfo()

R version 2.13.0 Under development (unstable) (2011-03-12 r54757) Platform: x86_64-pc-mingw32/x64 (64-bit)

locale:

[1] LC_COLLATE=English_United States.1252
[2] LC_CTYPE=English_United States.1252
[3] LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C
[5] LC_TIME=English_United States.1252

attached base packages:
[1] tools     stats     graphics  grDevices utils     datasets  methods
[8] base

Thanks
Dan

        [[alternative HTML version deleted]]



R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Wed 16 Mar 2011 - 20:39:50 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Thu 17 Mar 2011 - 08:40:33 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive