Re: [Rd] argument handling in boot.ci

From: Duncan Murdoch <murdoch.duncan_at_gmail.com>
Date: Wed, 23 Mar 2011 14:00:55 -0400

On 23/03/2011 11:35 AM, Matthew Vernon wrote:
> Hi,
>
> boot.ci fails to check if the "type" argument is valid or not. This
> tripped me up when I had a script that called boot.ci(type="normal",...)
> repeatedly - only later when I tried to do some further analysis did I
> realise I'd got nothing useful back from boot.ci.
>
> It strikes me that this behaviour is probably incorrect, and that
> boot.ci should stop if the "type" argument (or, indeed, any other
> supplied argument) is invalid. Am I correct?

boot.ci is in a contributed package (it's "Recommended", which means that a copy is distributed with R, but it is not part of R), so suggestions should go to the maintainer. But you need to put together a simple example to illustrate the problem. When I modify the first example in example(boot.ci) to specify type="normal", I get an error message.

Duncan Murdoch



R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Wed 23 Mar 2011 - 18:04:22 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Wed 23 Mar 2011 - 19:30:37 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive