Re: [Rd] Problem with dyn.load in R 2.13.0

From: Terry Therneau <>
Date: Wed, 13 Apr 2011 16:12:23 -0500

On Wed, 2011-04-13 at 16:45 -0400, Simon Urbanek wrote:
> We have no details, but my wild guess would be that you did not
> re-build the package for 2.13.0 and you have static libR in 2.13.0 yet
> dynamic in 2.12.2.
> Cheers,
> Simon

Per my prior note, my guess at the root of the issue is use of user libraries, which is common here.

Here are futher details if that helps.

 R2.13 was downloaded and built this AM in my ~/temp directory, using the standard
Then a copy of the shell script was copied to in ~therneau/bin/R13 for my convenience. I paid very little attention to the output of configure.

This is running on a shared server using CentOS release 5.5 (98 users at the moment).
R2.12.2 is centrally available.

> sessionInfo()

R version 2.13.0 RC (2011-04-11 r55409)
Platform: x86_64-unknown-linux-gnu (64-bit)


 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C              
 [3] LC_TIME=en_US.UTF-8        LC_COLLATE=C              
 [5] LC_MONETARY=C              LC_MESSAGES=en_US.UTF-8   
 [7] LC_PAPER=en_US.UTF-8       LC_NAME=C                 
 [9] LC_ADDRESS=C               LC_TELEPHONE=C            

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base   

I can't find a anywhere -- perhaps it's static.

tmt1119% pwd
tmt1120% find . -name 'libR*'


Thanks for everyone's help.

Terry mailing list Received on Wed 13 Apr 2011 - 21:14:40 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Thu 14 Apr 2011 - 06:00:45 GMT.

Mailing list information is available at Please read the posting guide before posting to the list.

list of date sections of archive