[R] GLM / Logistic Regression Problem

From: <patsko_at_gmx.de>
Date: Wed, 02 Mar 2011 17:10:43 +0100


Hi there,

I am encountering a problem with the GLM tool performing logistic regression. After computing a warning appears, saying “glm.fit: fitted probabilities numerically 0 or 1 occurred”. A prediction of new values confirms the problem as the model does not produce regular probability estimates but values which are way higher than 1 and lower than 0 in many cases. I have tried both methods setting the family=binomial and family=binomial(“logit”) so this can’t be the reason that causes the error.

As an alternative solution I have considered to resort to the Logistic tool from the RWeka package. The manual says that it exists for building multinomial logistic regression models. I can’t image it would be a problem but can anyone confirm that it indeed is possible to use the algorithm for also computing binary models?!

Best regards

Patrick

-- 
Schon gehört? GMX hat einen genialen Phishing-Filter in die

______________________________________________
R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Received on Wed 02 Mar 2011 - 20:40:17 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Wed 02 Mar 2011 - 21:10:18 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive