[R] how to set the starting value in lme

From: jia liu <proudlj_at_yahoo.com>
Date: Tue, 15 Mar 2011 12:34:44 -0700 (PDT)


Hi,
When I fit the mixed-effects model by lme, I got the convergence error code = 1 message = iteration limit reached without convergence (9). Even after I increase the iteration numbers, it still did not work. The only way I found to avoid the error message is to increase the number of iterations for the EM algorithm, which need to be at least 1100. But the weird thing is that the correlation between two random coefficients is always around 1, which is not true. So I am thinking the error should be related with the improper starting value. But I do not know how to set up my desired starting value in lme function. Are there anybody know it? Or met the same problem with me before and know how to avoid the error? Thank you for your help. Bests,
Jia

      
	[[alternative HTML version deleted]]


______________________________________________

R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Wed 16 Mar 2011 - 00:54:47 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Wed 16 Mar 2011 - 12:10:23 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive