Re: [R] Fwd: CRAN problem with plyr-1.4.1

From: Ian Davis <ian.w.davis_at_gmail.com>
Date: Tue, 12 Apr 2011 08:52:31 -0400

Uwe,

I really do appreciate the help from you and Douglas on resolving this problem. However, I respectfully disagree on a few points:

I'll repeat what I told Douglas -- as a user of R, it would be very helpful if the list of mirrors indicated which one(s) were authoritative (and by implication, which are unreliable).

Thanks again for your help, and for your work on maintaining R.

Best,
Ian

2011/4/12 Uwe Ligges <ligges_at_statistik.tu-dortmund.de>

>
>
> On 11.04.2011 21:03, Douglas Bates wrote:
>
>> The first thing to do is try another mirror. The "official" (or as
>> official as we ever get about anything) U.S. mirror is
>>
>> http://cran.us.R-project.org
>>
>> They tend to be very good about updating. Presently the source
>> package for plyr is at version 1.5 and the binary versions are both at
>> 1.4.1
>>
>
> Right, and on CRAN master the update process was running and hence you got
> a 440. Or in other words: Please just be a bit patient after a package was
> updated, the automated processes may take a day to complete. You can access
> the repositories without any problem using install.packages() and friends.
>
> Uwe Ligges
>
>
>
> On Mon, Apr 11, 2011 at 1:27 PM, Ian Davis<ian.w.davis_at_gmail.com> wrote:
>>> It looks like there might be some kind of problem with the Plyr-1.4.1
>>> packages pushed to CRAN? The web pages show 1.4.1 as the current
>>> version,
>>> but trying to fetch the source through the provided link gives a 404:
>>>
>>>
>>> http://lib.stat.cmu.edu/R/CRAN/web/packages/plyr/index.html
>>>
>>> $ wget http://lib.stat.cmu.edu/R/CRAN/src/contrib/plyr_1.4.1.tar.gz
>>> --2011-04-11 13:19:09--
>>> http://lib.stat.cmu.edu/R/CRAN/src/contrib/plyr_1.4.1.tar.gz
>>> Resolving lib.stat.cmu.edu... 128.2.241.212
>>> Connecting to lib.stat.cmu.edu|128.2.241.212|:80... connected.
>>> HTTP request sent, awaiting response... 404 Not Found
>>> 2011-04-11 13:19:09 ERROR 404: Not Found.
>>>
>>>
>>> This prevented me from installing ggplot2 until I went back and found an
>>> old
>>> version (1.4) of Plyr to install manually. Since it looks like Plyr was
>>> *just* updated a few days ago, I'm guessing something went awry? I
>>> checked
>>> several CRAN mirrors and got the same problem with all of them. They
>>> think
>>> the current version is 1.4.1, but they don't have any files available for
>>> download.
>>>
>>> Hope this helps,
>>> Ian
>>>
>>> [[alternative HTML version deleted]]
>>>
>>> ______________________________________________
>>> R-help_at_r-project.org mailing list
>>> https://stat.ethz.ch/mailman/listinfo/r-help
>>> PLEASE do read the posting guide
>>> http://www.R-project.org/posting-guide.html
>>> and provide commented, minimal, self-contained, reproducible code.
>>>
>>>
>> ______________________________________________
>> R-help_at_r-project.org mailing list
>> https://stat.ethz.ch/mailman/listinfo/r-help
>> PLEASE do read the posting guide
>> http://www.R-project.org/posting-guide.html
>> and provide commented, minimal, self-contained, reproducible code.
>>
>

        [[alternative HTML version deleted]]



R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Tue 12 Apr 2011 - 15:31:40 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Tue 12 Apr 2011 - 15:40:29 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive