Re: [R] Error Installing or Updating Packages (Maybe because of a proxy)

From: Uwe Ligges <ligges_at_statistik.tu-dortmund.de>
Date: Wed, 20 Apr 2011 10:29:17 +0200

If the internet connection from R works, can you please verify that you do not have any R base package from an old R version in a current R library that you may have in the .libPaths() already?

Uwe Ligges

On 20.04.2011 09:25, Majid Einian wrote:
> Dear R Helpers,
> (I am using Ubuntu lucid and R 2.13.0
> When I try to update packages I get this error:
>
>> update.packages()
> --- Please select a CRAN mirror for use in this session ---
> Loading Tcl/Tk interface ... done
> Error in ret[i, ]<- c(pkgs[i], lib, desc) :
> number of items to replace is not a multiple of replacement length
>
> I had no problem before (case 1) but now (case 2) I cannot get it to work,
> googleing did not help:
> case 1:
> * connecting directly without any proxy setting (at my university)
> * using R 2.12.2
> case 2:
> * connecting through proxy setting (at my workplace)
> * using R 2.13.0
>
> I set the proxy in terminal too but it does not help (echo $http_proxy gives
> me http://192.168.0.1:8080/)
>



R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Wed 20 Apr 2011 - 08:31:11 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Wed 20 Apr 2011 - 08:40:32 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive