[R] Error in png: unable to start png() device

From: Patrick McKann <pcmckann_at_gmail.com>
Date: Thu, 21 Apr 2011 12:37:17 -0500


Hello. I have made many pngs in the past, but started having trouble with them yesterday. I just downloaded R 2.13.0 this morning, and was able to make some pngs earlier this morning. Now I am trying to remake them, but get the same error message I got yesterday:

> u='in'
> w=10.5
> h=8
> png('winbugs changepoint graphs ind hibs gt 400
p%02d.png',height=h,width=w,res=300,units=u) Error in png("winbugs changepoint graphs ind hibs gt 400 p%02d.png", height = h, :
  unable to start png() device
In addition: Warning messages:
1: In png("winbugs changepoint graphs ind hibs gt 400 p%02d.png", height = h, :
  Unable to allocate bitmap
2: In png("winbugs changepoint graphs ind hibs gt 400 p%02d.png", height = h, :
  opening device failed

This exact same script worked an hour ago! I have tried closing R and re-opening it, but I am getting this error message every time now. I cannot make any sense of this, and the posts that I have found have not helped. One said that I could use bitmap(), but then I would need to install ghostscript, and I don't have priviliges to do so. If anybody knows how I can fix this, I would really appreciate some guidance.

        [[alternative HTML version deleted]]



R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Thu 21 Apr 2011 - 17:39:00 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Thu 21 Apr 2011 - 18:00:31 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive