[R] plot() under Rserve

From: Jonathan Shore <jonathan.shore_at_gmail.com>
Date: Tue, 26 Apr 2011 12:54:26 -0700 (PDT)


Hi,

Rserve allows one to render plots into jpeg with R code such as:

   jpeg(filename, ...)
   plot(...)
   dev.off()

However, substituting png, tiff, or bmp device redirection fails on Rserve with "eval error" on OSX.

   png(filename, ...)
   plot(...)
   dev.off()

The above in an eval produces an error and sometimes faults the connection. I suspect that Rserve is run in a mode where certain graphics parameters or shared libraries are not available?

Has anyone tried to render with Rserve to a device other than jpeg? The Java client demo uses jpeg, but will fail if changed to png.

Thanks

Jonathan

--
View this message in context: http://r.789695.n4.nabble.com/plot-under-Rserve-tp3476364p3476364.html
Sent from the R help mailing list archive at Nabble.com.

______________________________________________
R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Received on Tue 26 Apr 2011 - 20:25:27 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Tue 26 Apr 2011 - 20:30:33 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive