[R] system() command in R

From: rasanpreet kaur suri <rasanpreet.kaur_at_gmail.com>
Date: Mon, 04 Apr 2011 13:24:51 +0200


Hi all,
I have a local server insalled on my system and have to start that from within my R function.

here is how I start it:

cmd<-"sh start-server.sh"

system(cmd, wait=FALSE)

My function has to start the server and proceed with further steps. The server starts but the further steps of the program are not executed.The cursor keeps waiting after the server is started.

i tried removing the wait=FALSE, but it still keeps waiting.

I also tried putting the start-server in a separate function and my further script in a separate function and then run them together, but it still waits. The transition from the start of server to next step is not happening.

Please help. I have been stuck on this for quite some time now.

-- 
Rasanpreet Kaur

	[[alternative HTML version deleted]]

______________________________________________
R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Received on Mon 04 Apr 2011 - 12:11:37 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Tue 05 Apr 2011 - 08:40:27 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive