Re: [R] Sweave: no eps fig

From: Marc Schwartz <marc_schwartz_at_me.com>
Date: Fri, 06 May 2011 19:51:50 -0500

On May 6, 2011, at 6:00 PM, mk90-40_at_gmx.de wrote:

> Hi everyone,
>
> I'm using R, Latex and Sweave for some years now, but today it confuses me alot:
>
> Running Sweave produces only figures in .pdf format, no .eps figures.
>
> The header looks like this:
> <<echo=TRUE, fig=TRUE, label=Fig1>>=
>
> There was no error message.
>
> Does anybody have an idea?
> Any changes in the Sweave-package?
>
> Or a missing driver or something like that?
> I recently switched to another OS (Fedora RedHat) - might that be the reason?
>
> Grateful for any suggestions,
> Lena

Starting with R 2.13.0, the default in Sweave is to produce only PDF and not EPS.

You really only need EPS plots if you are doing postscript magic (eg. PSTricks, which I use) and need to use latex rather than pdflatex.

>From news():

o The default for Sweave() is to produce only PDF figures (rather

    than both EPS and PDF).

Always a good idea to read news() if running a new version... :-)

See ?RweaveLatex

You can either set:

  <<echo=TRUE, fig=TRUE, label=Fig1, eps=true>>=

or globally:

  \SweaveOpts{eps=true}

HTH, Marc Schwartz



R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Sat 07 May 2011 - 00:53:29 GMT

This quarter's messages: by month, or sorted: [ by date ] [ by thread ] [ by subject ] [ by author ]

All messages

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Sat 07 May 2011 - 02:10:06 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive