Re: [R] svytable and na's

From: Thomas Lumley <tlumley_at_uw.edu>
Date: Fri, 20 May 2011 09:48:14 +1200

On Thu, May 19, 2011 at 11:41 PM, Manderscheid Katharina <Katharina.Manderscheid_at_unilu.ch> wrote:
> hi,
>
> i am trying to work with the survey package in order to apply survey design weights. the data set i am using - ess - contains missing values.
> my question: when using svytable(~variable1+variable2, design=my.svydesign.object, na.rm=T) the resulting crosstable contains all missings although i defined the na's as such.
>

Could you give more details? There isn't an na.rm= argument to svytable, so it's not surprising it has no effect, but I don't know what you mean when you say the table "contains all missings." Perhaps you could show us the output and say how it differs from what you expected.

     -thomas

-- 
Thomas Lumley
Professor of Biostatistics
University of Auckland

______________________________________________
R-help_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Received on Thu 19 May 2011 - 21:51:15 GMT

This quarter's messages: by month, or sorted: [ by date ] [ by thread ] [ by subject ] [ by author ]

All messages

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Fri 20 May 2011 - 08:30:08 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.

list of date sections of archive