Re: [Rd] Debugging namespace problems

From: Martin Morgan <mtmorgan_at_fhcrc.org>
Date: Fri, 23 Dec 2011 14:56:28 -0800

On 12/23/2011 02:38 PM, Hadley Wickham wrote:
>>> in scales_add_defaults, where the symbol isn't found in the globalenv()
>>> when nstest is attached and ggplot2 only loaded, but is (via the search
>>> path) when ggplot2 is attached.
>>
>> and topenv(parent.frame()) is a replacement that gets to .GlobalEnv for
>> ggplot2, and to the name space for nstest.
>
> Wonderful - thanks! Any hints on how you discovered the problem?

nothing clever to report; it reproduces at the command line so traceback(), options(error=recover), and then debug(ggplot2::ggplot_build).

Martin

>
> Hadley
>

-- 
Computational Biology
Fred Hutchinson Cancer Research Center
1100 Fairview Ave. N. PO Box 19024 Seattle, WA 98109

Location: M1-B861
Telephone: 206 667-2793

______________________________________________
R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Fri 23 Dec 2011 - 22:58:20 GMT

This quarter's messages: by month, or sorted: [ by date ] [ by thread ] [ by subject ] [ by author ]

All messages

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Sat 24 Dec 2011 - 17:40:21 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive