Re: [Rd] Using custom R_LIBS with R CMD install

From: Hadley Wickham <hadley_at_rice.edu>
Date: Wed, 08 Feb 2012 12:36:16 -0600

> I wonder it works that far. It won't for me on Windows nor Linux, because
> system2 passes the whole thing shQuoted to the shell. Hence it is highly
> shell dependent what happens with the ill formed command.

Well I was using the env argument to system2, which claims to be cross-platform (at least for R and make). This command:

R_LIBS=/Users/hadley/R-dev R CMD INSTALL aL3xa-rapport-08e68ca/

is ok, isn't it?

> Whay not specify --library= in R CMD INSTALL if you are calling it
> programatically from R anyway?

My understanding (from reading R CMD INSTALL --help) was that --library was for specifying the destination library. Here I want to specify the full libpath - i.e. some of the packages that this package depends on may be in library 1, others may be in library 2. Have I misunderstood the documentation?

Hadley

-- 
Assistant Professor / Dobelman Family Junior Chair
Department of Statistics / Rice University
http://had.co.nz/

______________________________________________
R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Wed 08 Feb 2012 - 18:39:57 GMT

This quarter's messages: by month, or sorted: [ by date ] [ by thread ] [ by subject ] [ by author ]

All messages

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Wed 08 Feb 2012 - 19:30:16 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive