Re: [Rd] Using custom R_LIBS with R CMD install

From: Hadley Wickham <hadley_at_rice.edu>
Date: Thu, 09 Feb 2012 07:32:51 -0600

>>
>> To clarify, system2 doesn't work in windows?
>
> It does.
>
>> The system2
>>
>> documentation has: " On Windows, ‘env’ is currently only supported for
>> commands such as ‘R’ and ‘make’ which accept environment variables on
>> their command line."
>
> Yes, but "R CMD INSTALL" does not accept those variables in the command
> line. This could perhaps be improved given someone finds some time to do it.

Ok, so R does, but R CMD INSTALL does not. That was the source of my confusion - thanks for clearing that up!

However, is there a reason that system2 doesn't use the more general technique of Sys.setenv?

Hadley

-- 
Assistant Professor / Dobelman Family Junior Chair
Department of Statistics / Rice University
http://had.co.nz/

______________________________________________
R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Thu 09 Feb 2012 - 13:47:33 GMT

This quarter's messages: by month, or sorted: [ by date ] [ by thread ] [ by subject ] [ by author ]

All messages

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Thu 09 Feb 2012 - 15:40:16 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive