Re: [Rd] Rserve compilation error

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Wed, 07 Mar 2012 13:58:16 +0000

On 06/03/2012 18:08, jbanerjee wrote:
> Hi,
>
> I am trying to install Rserve 1.7-0 on CentOS 6. But I get this compilation
> error -
> /usr/lib64/Revo-5.0/R-2.13.2/lib64/R/lib/libiomp5.so: undefined reference to
> `pthread_atfork'
> I tried other versions of Rserve (0.6-5 and 0.6-8) without any success.
> How do I get around this issue? My goal is to run FastRWeb (which uses
> Rserve).

That message is not from compilation (it is a linker message), and in any case comes from the (non-R-core) build of R you used. R as distributed does not have any such library in $R_HOME/lib, so I think you need to ask the people who built your R (presumably Revolution) for help.

-- 
Brian D. Ripley,                  ripley_at_stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Wed 07 Mar 2012 - 14:01:32 GMT

This quarter's messages: by month, or sorted: [ by date ] [ by thread ] [ by subject ] [ by author ]

All messages

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Thu 08 Mar 2012 - 12:40:26 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive