Re: [Rd] windows() device: plot does not refresh with new drawing after opening and closing a new device

From: Duncan Murdoch <murdoch.duncan_at_gmail.com>
Date: Thu, 15 Mar 2012 06:54:26 -0400

On 12-03-15 2:29 AM, Michael Sumner wrote:
> Hello,
>
> I see this problem in 2.14.1, a recent dev, and 2.15.0 alpha, but not
> in an older build.
>
> Start the R windows console and run this code:
>
> plot(1:10);windows();dev.off();points(10:1)
>
> The second set of points does not show up until the window is
> minimized and restored.

Definitely looks like a bug. I'll see if I can track it down.

Duncan Murdoch

>
> If the device is replaced with a file-based one (pdf, png) there's no problem.
>
> I see this behaviour on these versions:
>
> R version 2.15.0 alpha (2012-03-13 r58726)
> Platform: x86_64-pc-mingw32/x64 (64-bit)
>
> R Under development (unstable) (2012-02-28 r58513)
> Platform: x86_64-pc-mingw32/x64 (64-bit)
>
> R version 2.14.1 (2011-12-22)
> Platform: x86_64-pc-mingw32/x64 (64-bit)
>
> I have an old beta install of 2.13.2 where the problem does not occur:
>
> R version 2.13.2 beta (2011-09-22 r57035)
> Platform: x86_64-pc-mingw32/x64 (64-bit)
>
> Cheers, Mike.
>
>



R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Thu 15 Mar 2012 - 11:05:01 GMT

This quarter's messages: by month, or sorted: [ by date ] [ by thread ] [ by subject ] [ by author ]

All messages

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Thu 15 Mar 2012 - 18:40:30 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive