Re: [Rd] 7 arguments passed to .Internal(identical) which requires 6

From: Matthew Dowle <mdowle_at_mdowle.plus.com>
Date: Thu, 07 Jun 2012 11:12:37 +0100

Prof Ripley wrote :
> (AFAIK the CRAN binary package providers expect users to be
> using the current version of R.)

I guess it's quite common practice for very many users to fail that expectation. I for one do. I'm used to seeing "Warning: package <x> was build using <the latest R>" when installing from CRAN. But if the package states "Depends (R >= 2.12.0)", for example, then I assume it's ok to use it in R 2.14.1, for instance. As long as it passes its test suite in the version of R I'm using, that's the main thing. Is that wrong?

Matthew



R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Thu 07 Jun 2012 - 10:18:04 GMT

This quarter's messages: by month, or sorted: [ by date ] [ by thread ] [ by subject ] [ by author ]

All messages

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Thu 07 Jun 2012 - 10:52:17 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive