Re: [Rd] 7 arguments passed to .Internal(identical) which requires 6

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Thu, 07 Jun 2012 13:14:07 +0100

On 07/06/2012 12:49, Matthew Dowle wrote:
>> On 07/06/2012 11:40, Matthew Dowle wrote:
>>>
>>> Prof Ripley wrote :
>>>> That Depends line is about source installs.
>>>
>>> I can't see that documented in either Writing R Extensions or
>>> ?install.packages. Is it somewhere else? I thought Depends applied to
>>> binaries from CRAN too, which is the default method on Windows and Mac.
>>
>> That field is documented under the description of a *source* package
>> (see the first line of section 1.1, and it is in that section) and is
>> simply copied from the source package for binary installs. It is the
>> extra line added to the DESCRIPTION file, e.g.
>>
>> Built: R 2.15.0; x86_64-pc-mingw32; 2012-04-02 09:27:07 UTC; windows
>>
>> that tells you the version a binary package was built under
>> (approximately for R-patched and R-devel), and library() checks.
>
> I'm fairly sure I understand all that. I'm still missing something more
> basic probably. Consider the follow workflow :
>
> I look on CRAN at package boot. Its webpage states "Depends R (>=
> 2.14.0)". I'm a user running R and I know I use 2.14.1, so I think great I
> can use it. I install it as follows.
>
>> version
> version.string R version 2.14.1 (2011-12-22)

>> install.packages("boot")
> trying URL
> '
http://cran.ma.imperial.ac.uk/bin/windows/contrib/2.14/boot_1.3-4.zip'
> Content type 'application/zip' length 469615 bytes (458 Kb)
> opened URL
> downloaded 458 Kb
>
> package ‘boot’ successfully unpacked and MD5 sums checked
>
>> require(boot)
> Loading required package: boot
> Warning message:
> package ‘boot’ was built under R version 2.14.2
>>
>
> Does this mean that CRAN maintainers expect me to run the latest version
> of the major release I'm using (R 2.14.2 in this case), not the current
> release of R (R 2.15.0 currently) as you wrote earlier? If that's the

> case I never realised it before, but that seems very reasonable. When I
> ran the above just now I expected it to say "package 'boot' was built
> under R version 2.15.0". But it didn't, it said 2.14.2. So it seems to
> be my misunderstanding.

2.15.x and 2.14.x are different series, with different binary repos.

>
> Matthew
>
>
>

-- 
Brian D. Ripley,                  ripley_at_stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Thu 07 Jun 2012 - 12:16:14 GMT

This quarter's messages: by month, or sorted: [ by date ] [ by thread ] [ by subject ] [ by author ]

All messages

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Thu 07 Jun 2012 - 17:42:21 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive