Re: [Rd] Build from Source fails on Loading required package Matrix

From: Dan Murphy <chiefmurphy_at_gmail.com>
Date: Wed, 15 Aug 2012 08:53:36 -0700

On Wed, Aug 15, 2012 at 8:04 AM, Simon Urbanek <simon.urbanek_at_r-project.org> wrote:
>
> Dan,
>
> On Aug 15, 2012, at 10:54 AM, Dan Murphy <chiefmurphy@gmail.com> wrote:
>
> > Hello:
> >
> > I am building R 2.15.1 from source on a Windows 7 machine with the x64
> > toolset, MixTeX, and InnoSetup per
> > http://cran.r-project.org/bin/windows/Rtools/. I obtained the source for
> > 2.15.1 via svn from https://svn.r-project.org/R/branches/R-2-15-branch/.
>
> Did you also rsync the recommended packages? They are not in the SVN. If
> in doubt, use released source tar balls.
>
> Cheers,
> Simon
>
Thanks, Simon. I should have mentioned that as well. Yes, I did "make rsync-recommended" per Chapter 3 of the manual and that worked without error.

I first inadvertently had tried to build the 2.16 version in /trunk and got that "undefined exports" error, then switched to the /R-2-15-branch when I realized /trunk held the development version.

In between the two svn checkouts, I had tried the source tar ball at the link R-2.15.1.tar.gz. That terminated much sooner in the build, which I thought could have resulted from me using 7-Zip on the tar ball (lacking a windows version of your tar), so I went back to the subversion checkout method.

>
>
> > This is my first try building R from source. The build seems to go far,
> > then terminates with "undefined exports: .M.classEnv" from the Matrix
> > package, I believe. Here are the last few lines of the build session
> >
> > Creating a generic function for 'qr.resid' from package 'base' in
> > package
> > 'Matrix'
> > Creating a generic function for 'qr.fitted' from package 'base' in
> > package
> > 'Matrix'
> > ** help
> > *** installing help indices
> > ** building package indices
> > Loading required package: Matrix
> > Error in namespaceExport(ns, exports) : undefined exports: .M.classEnv
> > Error : require(Matrix) is not TRUE
> > ERROR: installing package indices failed
> > * removing 'C:/Users/Dan/Documents/R-2.15.1/library/Matrix'
> > make[1]: *** [Matrix.ts] Error 1
> > make: *** [recommended] Error 2
> >
> > Perhaps there are special settings I should be making in MkRules.local?
> > My
> > only modification was MULTI = 64.
> >
> > Thanks in advance for your help.
> >
> > Dan Murphy
> >
> > [[alternative HTML version deleted]]
> >
> > ______________________________________________
> > R-devel_at_r-project.org mailing list
> > https://stat.ethz.ch/mailman/listinfo/r-devel
> >
> >
>



R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Wed 15 Aug 2012 - 15:55:38 GMT

This quarter's messages: by month, or sorted: [ by date ] [ by thread ] [ by subject ] [ by author ]

All messages

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Wed 15 Aug 2012 - 17:50:39 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive