Re: [Rd] How to build a list with missing values? What is missing, anyway?

From: Thomas Lumley <tlumley_at_uw.edu>
Date: Mon, 08 Oct 2012 08:54:54 +1300

On Fri, Oct 5, 2012 at 4:07 PM, Bert Gunter <gunter.berton_at_gene.com> wrote:
> On Thu, Oct 4, 2012 at 6:31 PM, Peter Meilstrup

>> explain some things, such as under what circumstances one would get a
>> "`...` used in incorrect context" error.
>
> How could it possibly know that?
>
> -- Bert

By looking at the code that throws the error.

The code is in src/main/eval.c, and the error is thrown in several places when the symbol ... appears in a call being evaluated, and the value of the symbol is neither the special DOTSXP type nor NULL. That is, if you use ... in code and there isn't a ... formal argument in scope.

   -thomas

-- 
Thomas Lumley
Professor of Biostatistics
University of Auckland

______________________________________________
R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Sun 07 Oct 2012 - 19:57:32 GMT

This quarter's messages: by month, or sorted: [ by date ] [ by thread ] [ by subject ] [ by author ]

All messages

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Mon 08 Oct 2012 - 13:30:46 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive