Re: [Rd] install.packages() fails if .libPaths() set

From: Uwe Ligges <ligges_at_statistik.tu-dortmund.de>
Date: Tue, 30 Oct 2012 15:03:42 +0100

On 30.10.2012 15:01, Hadley Wickham wrote:
>>> * installing *source* package ‘relations’ ...
>>> ...
>>> ** testing if installed package can be loaded
>>> *** arch - i386
>>> Error : package ‘sets’ required by ‘relations’ could not be found
>>> Error: loading failed
>>> Execution halted
>>> *** arch - x86_64
>>> Error : package ‘sets’ required by ‘relations’ could not be found
>>> Error: loading failed
>>> Execution halted
>>> ERROR: loading failed for ‘i386’, ‘x86_64’
>>>
>>> If I don't set .libPaths() it installs without error.
>>
>>
>> Yes, since your package set is installed in a library that is not "test".
>> And you have omitted that library from the search path by changing
>> .libPaths().

>
> I'm not sure I follow. I thought install.packages() installs into the
> first element of .libPaths(), and indeed I get this message:
>
> Installing package into ‘/Users/hadley/Desktop/test’
> (as ‘lib’ is unspecified)

Yes, but "sets" is not there.

Uwe

>
> Hadley
>
>

______________________________________________
R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Tue 30 Oct 2012 - 14:06:03 GMT

This quarter's messages: by month, or sorted: [ by date ] [ by thread ] [ by subject ] [ by author ]

All messages

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Tue 30 Oct 2012 - 14:50:51 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive