Re: [Rd] Unexpected source() behavior in R-devel

From: Sean Davis <sdavis2_at_mail.nih.gov>
Date: Mon 04 Sep 2006 - 11:04:30 GMT

Peter Dalgaard wrote:
> Sean Davis <sdavis2@mail.nih.gov> writes:
>
>
>> Why am I seeing the following in R-devel (sept 2, 2006 build) on opensuse
>> 10.1? I'm sure it is something simple I am missing, but I just don't see it
>> (output below).
>>
>> Thanks,
>> Sean
>>
>>
>>
>>> readLines(url("http://www.bioconductor.org/biocLite.R"))
>>>
>> [1] "source(\"http://bioconductor.org/getBioC.R\")"
>> [2] ""
>> [3] "biocLite <- function(pkgs, groupName=\"lite\", ...)"
>> [4] "{"
>> [5] " if (missing(pkgs))"
>> [6] " getBioC(groupName=groupName, ...)"
>> [7] " else"
>> [8] " getBioC(pkgs=pkgs, groupName=groupName, ...)"
>> [9] "}"
>>
>>> source(url("http://www.bioconductor.org/biocLite.R"))
>>>
>> Error in file(file, "r", encoding = encoding) :
>> unable to open connection
>> In addition: Warning message:
>> cannot open: HTTP status was '404 Not Found'
>>
>>> sessionInfo()
>>>
>> R version 2.4.0 Under development (unstable) (2006-09-02 r39068)
>> x86_64-unknown-linux-gnu
>>
>> locale:
>> LC_CTYPE=en_US.UTF-8;LC_NUMERIC=C;LC_TIME=en_US.UTF-8;LC_COLLATE=en_US.UTF-8;LC_MONETARY=en_US.UTF-8;LC_MESSAGES=en_US.UTF-8;LC_PAPER=en_US.UTF-8;LC_NAME=C;LC_ADDRESS=C;LC_TELEPHONE=C;LC_MEASUREMENT=en_US.UTF-8;LC_IDENTIFICATION=C
>>
>> attached base packages:
>> [1] "methods" "stats" "graphics" "grDevices" "utils" "datasets"
>> [7] "base"
>>
>
> Hmm, something is up. I got
>
>
>> source(url("http://www.bioconductor.org/biocLite.R"))
>>
> Error in file(file, "r", encoding = encoding) :
> unable to open connection
> In addition: Warning message:
> cannot open: HTTP status was '404 Not Found'
>
>> source(url("http://www.bioconductor.org/biocLite.R"))
>>
>
> *** caught segfault ***
> address 0x21, cause 'memory not mapped'
>
> Traceback:
> 1: file(file, "r", encoding = encoding)
> 2: source("
http://bioconductor.org/getBioC.R")
> 3: eval.with.vis(expr, envir, enclos)
> 4: eval.with.vis(ei, envir)
> 5: source(url("http://www.bioconductor.org/biocLite.R"))
>
> Possible actions:
> 1: abort (with core dump)
> 2: normal R exit
> 3: exit R without saving workspace
> 4: exit R saving workspace
> Selection:
>
>
> Oops...
>
> The immediate cause would seem to be that
> http://bioconductor.org/getBioC.R is non-existent (needs to be
> www.bioconductor.org).
>
> That's a server-side issue, not an R problem, but what was that bit
> with the segfault? I can't seem to reproduce it in a fresh session.
>
>
Thanks, Peter, for pointing out the obvious. I'll talk to the bioc folks.

On that other point, I have not gotten any segmentation faults so far. If I do, I'll repost.

Sean



R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Mon Sep 04 12:18:26 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Wed 06 Sep 2006 - 11:39:23 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.