[Rd] R CMD check: unstated dependence on a standard package.

From: Henrik Bengtsson <hb_at_stat.berkeley.edu>
Date: Thu 07 Sep 2006 - 23:14:07 GMT


In the recent R-devel version, I receive the following error:

It looks like this package (or one of its dependent packages) has an unstated dependence on a standard package. All dependencies must be declared in DESCRIPTION.
See the information on DESCRIPTION files in the chapter 'Creating R
packages' of the 'Writing R Extensions' manual.

I found the following comment in NEWS.R-2.5.0dev under "CHANGES IN R VERSION 2.4.0" related to two packages only:

When I add 'utils' to "Depends:" in the DESCRIPTION file the error goes away. Could you please confirm that you from now on have to specify also the 'utils' package and other standard package in Depends?

Thanks

Henrik



R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Fri Sep 08 09:16:53 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Fri 08 Sep 2006 - 07:30:07 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.