Re: [Rd] install.packages(,type="source") broken on Windows

From: Peter Dalgaard <p.dalgaard_at_biostat.ku.dk>
Date: Sat 09 Sep 2006 - 00:15:00 GMT

hpages@fhcrc.org writes:

> Hi,
>

> On Windows, 'install.packages(,type="source")' displays the same output
> than 'R CMD INSTALL --help' and doesn't install anything...

Yes. The culprit is



r39127 | urbaneks | 2006-09-05 20:45:00 +0200 (Tue, 05 Sep 2006) | 1 line

Bugfix: install.packages ignored unnamed configure.args


which forgets to check whether there are any args to name. (There is a generic issue in that available.packages has a configure.args argument which is passed on to --configure-args in the INSTALL script: The Windows INSTALL doesn't understand the argument since configure doesn't work on Windows. However, things should work when no such arguments are passed.)

-- 
   O__  ---- Peter Dalgaard             ุster Farimagsgade 5, Entr.B
  c/ /'_ --- Dept. of Biostatistics     PO Box 2099, 1014 Cph. K
 (*) \(*) -- University of Copenhagen   Denmark          Ph:  (+45) 35327918
~~~~~~~~~~ - (p.dalgaard@biostat.ku.dk)                  FAX: (+45) 35327907

______________________________________________
R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Sat Sep 09 10:17:24 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Sat 09 Sep 2006 - 01:30:06 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.