Re: [Rd] install.packages(,type="source") broken on Windows

From: Herve Pages <hpages_at_fhcrc.org>
Date: Sat 09 Sep 2006 - 01:16:24 GMT

OK thanks. Just FYI the same thing happens with R version 2.5.0 devel (2006-09-07 r39185).
Best,

H.

Peter Dalgaard wrote:
> hpages@fhcrc.org writes:
>
>
>> Hi,
>>
>> On Windows, 'install.packages(,type="source")' displays the same output
>> than 'R CMD INSTALL --help' and doesn't install anything...
>>
>
> Yes. The culprit is
>
> ------------------------------------------------------------------------
> r39127 | urbaneks | 2006-09-05 20:45:00 +0200 (Tue, 05 Sep 2006) | 1 line
>
> Bugfix: install.packages ignored unnamed configure.args
> ------------------------------------------------------------------------
>
> which forgets to check whether there are any args to name. (There is a
> generic issue in that available.packages has a configure.args argument
> which is passed on to --configure-args in the INSTALL script: The
> Windows INSTALL doesn't understand the argument since configure
> doesn't work on Windows. However, things should work when no such
> arguments are passed.)
>
>

-- 
------------------------
Hervé Pagès
E-mail: hpages@fhcrc.org
 Phone: (206) 667-5791
   Fax: (206) 667-1319

______________________________________________
R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Sat Sep 09 11:19:12 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Mon 11 Sep 2006 - 11:30:08 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.