[Rd] segfault in plot(x, y, col = aFactor) (PR#9221)

From: <bhx5_at_mevik.net>
Date: Tue 12 Sep 2006 - 14:35:19 GMT


After the following commands (issued just after starting R)

set.seed(1)

n <- 600
x <- rnorm(n)
y <- rnorm(n)

aFactor <- factor(rep(1:5, length = n))
plot(x, y, col = aFactor)

R prints

and dies.

(Yes, I know that using a factor as `col' is wrong; I discovered this by a mistake. :-)

Substituting "aFactor <- factor(rep(1:5, length = n))" with "aFactor <- rep(1:5, length = n)" (obviously) works as expected.

When n is smaller, for instance 400, no seg.fault seems to happen.

I also tested this on R 2.3.1 (that's actually where I discovered it :-), and the same thing happens there.

--please do not edit the information below--

Version:
 platform = x86_64-unknown-linux-gnu
 arch = x86_64
 os = linux-gnu
 system = x86_64, linux-gnu
 status = alpha
 major = 2
 minor = 4.0
 year = 2006
 month = 09
 day = 11
 svn rev = 39258
 language = R
 version.string = R version 2.4.0 alpha (2006-09-11 r39258)

Locale:
LC_CTYPE=no_NO.UTF-8;LC_NUMERIC=C;LC_TIME=no_NO.UTF-8;LC_COLLATE=no_NO.UTF-8;LC_MONETARY=no_NO.UTF-8;LC_MESSAGES=no_NO.UTF-8;LC_PAPER=no_NO.UTF-8;LC_NAME=C;LC_ADDRESS=C;LC_TELEPHONE=C;LC_MEASUREMENT=no_NO.UTF-8;LC_IDENTIFICATION=C

Search Path:
 .GlobalEnv, package:methods, package:stats, package:graphics, package:grDevices, package:utils, package:datasets, Autoloads, package:base

-- 
Bjørn-Helge Mevik

______________________________________________
R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Wed Sep 13 00:43:19 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Tue 12 Sep 2006 - 16:27:55 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.