[R] problem with png

From: David Ziger <David.Ziger_at_synopsys.com>
Date: Fri 01 Sep 2006 - 04:08:04 GMT


I cannot generate png files running R2.2.1 on a SunOS 5.9 machine. See below. I did a search on this problem and people who have virtually the same error have solved the problem by installing or updating libpng . We downloaded libpng from Sun but still the problem remains. Does a path within R need to be set to this file or does the problem indicate that libpng was not installed properly? I have no problems running on various Linux OS's or a SunOS 5.8 machine. I appreciate any help on this issue. We are using R2.2.1  

David Ziger

Synopsys, Inc  

> x <- c(1,2,3)
> y <- c(2,4,6)
> plot(x,y)

> png(file="myplot.png", bg="transparent")
Error in X11(paste("png::", filename, sep = ""), width, height, pointsize, :

        unable to start device PNG
In addition: Warning message:
no png support in this version of R  

> capabilities(what=NULL)

    jpeg      png    tcltk      X11 http/ftp  sockets   libxml     fifo 
   FALSE    FALSE     TRUE     TRUE     TRUE     TRUE     TRUE     TRUE 
  cledit    iconv      NLS 
   FALSE    FALSE     TRUE

 

 


	[[alternative HTML version deleted]]

______________________________________________
R-help@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code. Received on Fri Sep 01 14:53:12 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Thu 07 Sep 2006 - 07:51:16 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.